xiaoheidouqq 发表于 2011-5-25 09:33:00

CISCO路由器常用配置命令

                                                CISCO路由器常用配置命令

1.启动接口,分配IP地址:
  router>
  router> enable
  router#
  router# configure terminal
  router(config)#
  router(config)# interface Type Port
  router(config-if)# no shutdown
  router(config-if)# ip address IP-Address Subnet-Mask
  router(config-if)# ^z
2.配置RIP路由协议:30秒更新一次
  router(config)# router rip
  router(config-if)# network Network-Number <--通告标准A,B,C类网-->
  router(config-if)# ^z
3.配置IGRP路由协议:90秒更新一次
  router(config)# router igrp AS-Number <-- AS-Number范围1~65535-->
  router(config-if)# network Network-Number <--通告标准A,B,C类网-->
  router(config-if)# ^z
4.配置Novell IPX路由协议:Novell RIP 60秒更新一次
  router(config)# ipx routing
  router(config)# ipx maximum-paths Paths <--设置负载平衡,范围1~512-->
  router(config)# interface Type Port
  router(config-if)# ipx network Network-Number <--通告标准A,B,C类网-->
  router(config-if)# ^z
5.配置DDR:
  router(config)# dialer-list Group-Number protocol Protocol-Type permit
  router(config)# interface bri 0
  router(config-if)# dialer-group Group-Number
  router(config-if)# dialer map Protocol-Type Next-Hop-Address name Hostname Telphone-Number
  router(config-if)# ^z
6.配置ISDN:
  router(config)# isdn swith-type Swith-Type <--配置ISDN交换机类型,中国使用basic-net3-->
  router(config-if)# ^z
7.配置Frame Relay:
  router(config-if)# encapsulation frame-relay
  router(config-if)# frame-relay lmi-type
  router(config-if)# bandwidth kilobits
  router(config-if)# frame-relay invers-arp [ Protocol ]
8.<--配置静态Invers ARP表:
  router(config)# frame-relay Protocol Protocol-Address DLCI [ Broadcast ] [ ietf | cisco ] [ payload-compress | packet-by-packet ]
  -->
  <--设置Keepalive间隔:
  router(config-if)# keepalive Number
  -->
  <--为本地接口指定DLCI:
  router(config-if)# frame-lelay local-dlci Number
  -->
  <--子接口配置:
  router(config-if)# interface Type Port.Subininterface-Number [ multipoint | point-to-point ]
  router(config-subif)# ip unnumbered Interface
  router(config-subif)# frame-lelay local-dlci Number
  -->
  router(config-if)# ^z
9.配置标准ACL:
  router(config)# access-list Access-List-Number [ permit | deny ] source [ source-mask ] <-- Access-List-Number 范围:1~99标准ACL;100~199扩展ACL;800~899标准IPX ACL;900~999扩展IPX ACL;1000~1099 IPX SAP ACL;600~699Apple Talk ACL-->
  router(config)# interface Type Port
  router(config-if)# ip access-group Access-List-Number [ in | out ]
  router(config-if)# ^z
  配置扩展ACL:
  router(config)# access-list Access-List-Number [ permit | deny ] [ Protocol | Protocol-Number ] source source-wildcard [ Source-Port ] destination destination-wildcard [ Destination-Port ] [ established ]
  router(config)# interface Type Port
  router(config-if)# ip access-group Access-List-Number [ in | out ]
  router(config-if)# ^z
  配置命名ACL:
  router(config)# ip access-list [ standard | extended ] ACL-Name
  router(config [ std- | ext- ] nacl)# [ permit | deny ] [ IP-Access-List-Test-Conditions ]
  router(config [ std- | ext- ] nacl)# no [ permit | deny ] [ IP-Access-List-Test-Conditions ]
  router(config [ std- | ext- ] nacl)# ^z
  router(config)# interface Type Port
  router(config-if)# ip access-group [ in | out ]
  router(config-if)# ^z
10.配置DCE时钟:
  router# show controllers Type Port <--确定DCE接口-->
  router(confin-if)# clock rate 64000 <--进入DCE接口设置时钟速率-->
  router(config-if)# ^z
  配置PPP协议:
  router(config)# username Name password Set-Password-Here <--验证方建立数据库-->
  router(config)# interface Type Port
  router(config-if)# encapsulation ppp <--启动PPP协议-->
  router(config-if)# ppp outhentication [ chap | chap pap | pap chap | pap ] <--选择PPP认证-->
  router(config-if)# ppp pap sent-username Name password Password <--发送验证信息-->
  router(config-if)# ^z
11.PAP单向认证配置实例:
  验证方:
  router-server(config)# username Client password 12345 <--验证方建立数据库-->
  router-server(config)# interface serial 0
  router-server(config-if)# encapsulation ppp
  router-server(config-if)# ppp authentication pap <--选择使用PAP实现PPP认证-->
  router-server(config-if)# ^z
  被验证方:
  router-client(config-if)# encapsulation ppp
  router-client(config-if)# ppp pap sent-username Client password 12345 <--发送验证信息-->
  router-client(config-if)# ^z
  PAP双向认证配置实例:
  路由器 A:
  routerA(config)# username B password 12345
  routerA(config)# interface serial 0
  routerA(config-if)# encapsulation ppp
  routerA(config-if)# ppp authentication pap
  routerA(config-if)# ppp pap sent-username A password 54321
  routerA(config-if)# ^z
  路由器 B:
  routerB(config)# username A password 54321
  routerB(config)# interface serial 1
  routerB(config-if)# encapsulation ppp
  routerB(config-if)# ppp authentication pap
  routerB(config-if)# ppp pap sent-username B password 12345
  routerB(config-if)# ^z
12.CHAP单向认证配置实例:
  验证方:
  router-server(config)# username router-client password 12345
  router-server(config)# interface serial 0
  router-server(config-if)# encapsulation ppp
  router-server(config-if)# ppp authentication chap
  router-server(config-if)# ^z
  被验证方:
  router-client(config-if)# encapsulation ppp
  router-client(config-if)# ppp authentication chap
  router-client(config-if)# ppp chap hostname router-client
  router-client(config-if)# ppp chap password 12345
  router-client(config-if)# ^z
  CHAP双向认证配置实例:
  路由器 A:
  routerA(config)# username routerB password 12345
  routerA(config)# interface serial 0
  routerA(config-if)# encapsulation ppp
  routerA(config-if)# ppp authentication chap
  routerA(config-if)# ppp chap hostname routerA
  routerA(config-if)# ppp chap password 54321
  routerA(config-if)# ^z
  路由器 B:
  routerB(config)# username routerA password 54321
  routerB(config)# interface serial 1
  routerB(config-if)# encapsulation ppp
  routerB(config-if)# ppp authentication chap
  routerB(config-if)# ppp chap hostname routerB
  routerB(config-if)# ppp chap password 12345
  routerB(config-if)# ^z
  Telnet使用:
  routerA# terminal monitor <--可以传回在远端主机执行Debug命令的结果-->
  routerA# telnet IP-Address [ Router-Name ] <--Telnet到指定的地址或名字的主机-->
  routerB# [ exit | logout ] <--退出Telnet-->
  routerB# ++<6>再按 <--挂起Telnet-->
  routerA# show sessions <--显示当前所有Telnet的信息,包括Connect-Number -->
  routerA# Connect-Number <--返回指定的Telnet连接-->
  routerA# disconnect IP-Address [ Router-Name ] <--断开指定地址或名字的主机的连接-->
  routerA# show user <--显示Telnet到本机的连接信息-->
  routerA# clear line [ 0 | 1 | 2 | 3 | 4 ] <--断开指定Telnet到本机的连接-->
13.禁止任何Telnet到本机:
  router(config)# line vty 0 4
  router(config-line)# access-class ACL-Number
  router(config)# ^z
  设置主机名:
  router(config)# hostname Set-Hostname
  router(config)# ^z
  router(config)# ^z
  设置用户模式密码:
  router(config)# line console 0
  router(config-line)# login
  router(config-line)# password Set-Password
  router(config-line)# ^z
  设置Telnet密码:
  router(config)# line vty 0 4
  router(config-line)# login
  router(config-line)# password Set-Password
  router(config-line)# ^z
  设置特权模式密码:
  router(config)# enable password Set-Password <--不加密的密码,明码

本文转载自:

jialiang1010 发表于 2011-5-25 12:37:00

<p>虽然看不懂 但是学习啦!!!</p>

cxlgok 发表于 2011-6-9 22:06:00

看不懂

tyjlhh 发表于 2011-6-9 22:59:00

<p>谢谢</p>

advent64 发表于 2011-8-4 11:44:00

学习!!!!了

bieli3560582 发表于 2011-9-20 17:36:00

差不多都学过,温习一下

thexue2006 发表于 2012-5-10 22:48:00

公司过几天就要弄 个新的带光模的思科交换机,这个命令在什么地方输入……

yu547130970 发表于 2012-5-16 10:51:00

不错

cumanzai 发表于 2012-5-17 13:50:00

看不懂,以后在看

发表于 2012-5-27 20:02:00

<p>谢谢,楼主的资料真的很错。</p>
<p>&nbsp;</p>

yahong100 发表于 2012-5-28 11:39:00

<p>学习了···好东西呀··</p>

国超小詹 发表于 2012-5-28 11:52:00

<p>没看懂还是顶一下</p>
<p>&nbsp;</p>

xxd130134 发表于 2012-6-27 10:34:00

很多都忘记了 可以温习下
页: [1]
查看完整版本: CISCO路由器常用配置命令